What’s Vulnerable › Vulnerabilities
CVE-2021-27216
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-06 · updated 2026-06-17
- Weakness: CWE-362
Description
Exim 4 before 4.94.2 has Execution with Unnecessary Privileges. By leveraging a delete_pid_file race condition, a local user can delete arbitrary files as root. This involves the -oP and -oPX options.
Affected products
- Exim: before 4.94.2 — fixed in 4.94.2
How to fix
Upgrade to a fixed version: Exim 4.94.2. Check the vendor advisory for mitigations.
References
- https://www.exim.org/static/doc/security/CVE-2020-qualys/CVE-2020-28007-LFDIR.txt
- https://www.exim.org/static/doc/security/CVE-2020-qualys/CVE-2020-28007-LFDIR.txt
Get alerted when CVE-2021-27216 or the next vulnerability affects your stack