What’s Vulnerable › Vulnerabilities
CVE-2021-27218
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-15 · updated 2026-10-14
- Weakness: CWE-681
Description
An issue was discovered in GNOME GLib before 2.66.7 and 2.67.x before 2.67.4. If g_byte_array_new_take() was called with a buffer of 4GB or more on a 64-bit platform, the length would be truncated modulo 2**32, causing unintended length truncation.
Affected products
- Broadcom Brocade Fabric Operating System Firmware: all versions
- Debian Linux: 9.0
- Fedoraproject Fedora: 33, 34
- GNOME GLib: before 2.66.7; from 2.67.0 before 2.67.4 — fixed in 2.66.7, 2.67.4
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- NetApp Cloud Backup: all versions
- NetApp E-Series Performance Analyzer: all versions
How to fix
Upgrade to a fixed version: GNOME GLib 2.66.7, 2.67.4. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1942
- https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1944
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf9fa47ab66495c78bb4120b0754dd9531ca2ff0430f6685ac9b07772%40%3Cdev.mina.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2022/06/msg00006.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2REA7RVKN7ZHRLJOEGBRQKJIPZQPAELZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JJMPNDO4GDVURYQFYKFOWY5HAF4FTEPN/
- https://security.gentoo.org/glsa/202107-13
- https://security.netapp.com/advisory/ntap-20210319-0004/
- https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1942
- https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1944
Get alerted when CVE-2021-27218 or the next vulnerability affects your stack