What’s Vulnerable › Vulnerabilities

CVE-2021-27219

Description

An issue was discovered in GNOME GLib before 2.66.6 and 2.67.x before 2.67.3. The function g_bytes_new has an integer overflow on 64-bit platforms due to an implicit cast from 64 bits to 32 bits. The overflow could potentially lead to memory corruption.

Affected products

How to fix

Upgrade to a fixed version: GNOME GLib 2.66.6, 2.67.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-27219 or the next vulnerability affects your stack