What’s Vulnerable › Vulnerabilities
CVE-2021-27224
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 38.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-17 · updated 2026-06-17
- Weakness: CWE-787
Description
The WPG plugin before 3.1.0.0 for IrfanView 4.57 has a user-mode write access violation starting at WPG+0x0000000000012ec6, which might allow remote attackers to execute arbitrary code.
Affected products
- IrfanView Wpg: before 3.1.0.0 — fixed in 3.1.0.0
How to fix
Upgrade to a fixed version: IrfanView Wpg 3.1.0.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/161449/IrfanView-4.57-Denial-Of-Service-Code-Execution.html
- https://sec-consult.com/vulnerability-lab/advisory/multiple-vulnerabilities-irfanview-wpg/
- https://www.irfanview.com/plugins.htm
- http://packetstormsecurity.com/files/161449/IrfanView-4.57-Denial-Of-Service-Code-Execution.html
- https://sec-consult.com/vulnerability-lab/advisory/multiple-vulnerabilities-irfanview-wpg/
- https://www.irfanview.com/plugins.htm
Get alerted when CVE-2021-27224 or the next vulnerability affects your stack