What’s Vulnerable › Vulnerabilities
CVE-2021-27230
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-15 · updated 2026-06-17
- Weakness: CWE-94
Description
ExpressionEngine before 5.4.2 and 6.x before 6.0.3 allows PHP Code Injection by certain authenticated users who can leverage Translate::save() to write to an _lang.php file under the system/user/language directory.
Affected products
- ExpressionEngine: before 5.4.2; from 6.0.0 before 6.0.3 — fixed in 5.4.2, 6.0.3
How to fix
Upgrade to a fixed version: ExpressionEngine 5.4.2, 6.0.3. Check the vendor advisory for mitigations.
References
- http://karmainsecurity.com/KIS-2021-03
- http://packetstormsecurity.com/files/161805/ExpressionEngine-6.0.2-PHP-Code-Injection.html
- http://seclists.org/fulldisclosure/2021/Mar/32
- https://expressionengine.com/features
- https://hackerone.com/reports/1093444
- http://karmainsecurity.com/KIS-2021-03
- http://packetstormsecurity.com/files/161805/ExpressionEngine-6.0.2-PHP-Code-Injection.html
- http://seclists.org/fulldisclosure/2021/Mar/32
- https://expressionengine.com/features
- https://hackerone.com/reports/1093444
Get alerted when CVE-2021-27230 or the next vulnerability affects your stack