What’s Vulnerable › Vulnerabilities
CVE-2021-27330
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Triconsole Datepicker Calendar <3.77 is affected by cross-site scripting (XSS) in calendar_form.php. Attackers can read authentication cookies that are still active, which can be used to perform further attacks such as reading browser history, directory listings, and file contents.
Affected products
- Triconsole Datepicker Calendar: before 3.77 — fixed in 3.77
How to fix
Upgrade to a fixed version: Triconsole Datepicker Calendar 3.77. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/161570/Triconsole-3.75-Cross-Site-Scripting.html
- http://www.triconsole.com/
- http://www.triconsole.com/php/calendar_datepicker.php
- https://www.exploit-db.com/exploits/49597
- http://packetstormsecurity.com/files/161570/Triconsole-3.75-Cross-Site-Scripting.html
- http://www.triconsole.com/
- http://www.triconsole.com/php/calendar_datepicker.php
- https://www.exploit-db.com/exploits/49597
Get alerted when CVE-2021-27330 or the next vulnerability affects your stack