What’s Vulnerable › Vulnerabilities
CVE-2021-27362
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-17 · updated 2026-06-17
- Weakness: CWE-125
Description
The WPG plugin before 3.1.0.0 for IrfanView 4.57 has a Read Access Violation on Control Flow starting at WPG!ReadWPG_W+0x0000000000000133, which might allow remote attackers to execute arbitrary code.
Affected products
- IrfanView Wpg: before 3.1.0.0 — fixed in 3.1.0.0
How to fix
Upgrade to a fixed version: IrfanView Wpg 3.1.0.0. Check the vendor advisory for mitigations.
References
- https://sec-consult.com/vulnerability-lab/advisory/multiple-vulnerabilities-irfanview-wpg/
- https://www.irfanview.com/plugins.htm
- https://sec-consult.com/vulnerability-lab/advisory/multiple-vulnerabilities-irfanview-wpg/
- https://www.irfanview.com/plugins.htm
Get alerted when CVE-2021-27362 or the next vulnerability affects your stack