What’s Vulnerable › Vulnerabilities
CVE-2021-27377
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-18 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the yottadb crate before 1.2.0 for Rust. For some memory-allocation patterns, ydb_subscript_next_st and ydb_subscript_prev_st have a use-after-free.
Affected products
- Yottadb: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: Yottadb 1.2.0. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2021-0022.html
- https://rustsec.org/advisories/RUSTSEC-2021-0022.html
Get alerted when CVE-2021-27377 or the next vulnerability affects your stack