What’s Vulnerable › Vulnerabilities
CVE-2021-27400
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-22 · updated 2026-06-17
- Weakness: CWE-295
Description
HashiCorp Vault and Vault Enterprise Cassandra integrations (storage backend and database secrets engine plugin) did not validate TLS certificates when connecting to Cassandra clusters. Fixed in 1.6.4 and 1.7.1
Affected products
- HashiCorp Vault: before 1.6.4; from 1.7.0 before 1.7.1 — fixed in 1.6.4, 1.7.1
How to fix
Upgrade to a fixed version: HashiCorp Vault 1.6.4, 1.7.1. Check the vendor advisory for mitigations.
References
- https://discuss.hashicorp.com/t/hcsec-2021-10-vault-s-cassandra-integrations-did-not-validate-tls-certificates/23463
- https://discuss.hashicorp.com/t/hcsec-2021-10-vault-s-cassandra-integrations-did-not-validate-tls-certificates/23463
Get alerted when CVE-2021-27400 or the next vulnerability affects your stack