What’s Vulnerable › Vulnerabilities
CVE-2021-27501: Philips Vue PACS Improper Adherence to Coding Standards
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-01 · updated 2026-06-17
- Weakness: CWE-710
Description
Philips Vue PACS versions 12.2.x.x and prior does not follow certain coding rules for development, which can lead to resultant weaknesses or increase the severity of the associated vulnerabilities.
Affected products
- Philips Myvue: before 12.2.1.5 — fixed in 12.2.1.5
- Philips Speech: before 12.2.8.0 — fixed in 12.2.8.0
- Philips Vue Motion: before 12.2.1.5 — fixed in 12.2.1.5
- Philips Vue PACS: before 12.2.8.0 — fixed in 12.2.8.0
How to fix
Upgrade to a fixed version: Philips Myvue 12.2.1.5; Philips Speech 12.2.8.0; Philips Vue Motion 12.2.1.5; Philips Vue PACS 12.2.8.0. Check the vendor advisory for mitigations.
References
- http://www.philips.com/productsecurity
- https://www.cisa.gov/uscert/ics/advisories/icsma-21-187-01
- http://www.philips.com/productsecurity
- https://www.cisa.gov/uscert/ics/advisories/icsma-21-187-01
Get alerted when CVE-2021-27501 or the next vulnerability affects your stack