What’s Vulnerable › Vulnerabilities
CVE-2021-27751: HCL Commerce is affected by an Insufficient Session Expiration vulnerability.
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-06 · updated 2026-06-17
- Weakness: CWE-613
Description
HCL Commerce is affected by an Insufficient Session Expiration vulnerability. After the session expires, in some circumstances, parts of the application are still accessible.
Affected products
- HCL Software HCL Commerce: from 8.0.0.0 before 8.0.4.28; from 9.0.0.0 before 9.0.1.18; from 9.1.0 before 9.1.9 — fixed in 8.0.4.28, 9.0.1.18, 9.1.9
How to fix
Upgrade to a fixed version: HCL Software HCL Commerce 8.0.4.28, 9.0.1.18, 9.1.9. Check the vendor advisory for mitigations.
References
- https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0097650
- https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0097650
Get alerted when CVE-2021-27751 or the next vulnerability affects your stack