What’s Vulnerable › Vulnerabilities
CVE-2021-27790
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-12 · updated 2026-06-17
- Weakness: CWE-787
Description
The command ipfilter in Brocade Fabric OS before Brocade Fabric OS v.9.0.1a, v8.2.3, and v8.2.0_CBN4, and v7.4.2h uses unsafe string function to process user input. Authenticated attackers can abuse this vulnerability to exploit stack-based buffer overflows, allowing execution of arbitrary code as the root user account.
Affected products
- Brocade Fabric OS: before 7.4.2h; from 8.0.0 before 8.2.0_cbn4; from 8.2.1 before 8.2.3; from 9.0.0 before 9.0.1a — fixed in 7.4.2h, 8.2.0_cbn4, 8.2.3, 9.0.1a
How to fix
Upgrade to a fixed version: Brocade Fabric OS 7.4.2h, 8.2.0_cbn4, 8.2.3, 9.0.1a. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20210819-0002/
- https://www.broadcom.com/support/fibre-channel-networking/security-advisories/brocade-security-advisory-2021-1492
- https://security.netapp.com/advisory/ntap-20210819-0002/
- https://www.broadcom.com/support/fibre-channel-networking/security-advisories/brocade-security-advisory-2021-1492
Get alerted when CVE-2021-27790 or the next vulnerability affects your stack