What’s Vulnerable › Vulnerabilities
CVE-2021-27908
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-23 · updated 2026-06-17
- Weakness: CWE-200
Description
In all versions prior to Mautic 3.3.2, secret parameters such as database credentials could be exposed publicly by an authorized admin user through leveraging Symfony parameter syntax in any of the free text fields in Mautic’s configuration that are used in publicly facing parts of the application.
Affected products
- Mautic: before 3.3.2 — fixed in 3.3.2
How to fix
Upgrade to a fixed version: Mautic 3.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/mautic/mautic/security/advisories/GHSA-4hjq-422q-4vpx
- https://github.com/mautic/mautic/security/advisories/GHSA-4hjq-422q-4vpx
Get alerted when CVE-2021-27908 or the next vulnerability affects your stack