What’s Vulnerable › Vulnerabilities
CVE-2021-27909: XSS vulnerability on password reset page
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-79
Description
For Mautic versions prior to 3.3.4/4.0.0, there is an XSS vulnerability on Mautic's password reset page where a vulnerable parameter, "bundle," in the URL could allow an attacker to execute Javascript code. The attacker would be required to convince or trick the target into clicking a password reset URL with the vulnerable parameter utilized.
Affected products
- Mautic: before 3.3.4; 4.0.0-alpha1, 4.0.0-beta, 4.0.0-rc — fixed in 3.3.4
How to fix
Upgrade to a fixed version: Mautic 3.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/mautic/mautic/security/advisories/GHSA-32hw-3pvh-vcvc
- https://github.com/mautic/mautic/security/advisories/GHSA-32hw-3pvh-vcvc
Get alerted when CVE-2021-27909 or the next vulnerability affects your stack