What’s Vulnerable › Vulnerabilities
CVE-2021-27912: XSS vulnerability on asset view
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Mautic versions before 3.3.4/4.0.0 are vulnerable to an inline JS XSS attack when viewing Mautic assets by utilizing inline JS in the title and adding a broken image URL as a remote asset. This can only be leveraged by an authenticated user with permission to create or edit assets.
Affected products
- Mautic: before 3.3.4; 4.0.0-alpha1, 4.0.0-beta, 4.0.0-rc — fixed in 3.3.4
How to fix
Upgrade to a fixed version: Mautic 3.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/mautic/mautic/security/advisories/GHSA-rh5w-82wh-jhr8
- https://github.com/mautic/mautic/security/advisories/GHSA-rh5w-82wh-jhr8
Get alerted when CVE-2021-27912 or the next vulnerability affects your stack