What’s Vulnerable › Vulnerabilities
CVE-2021-27915: XSS Cross-site Scripting Stored (XSS) - Description field
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-17 · updated 2026-06-17
- Weakness: CWE-80
Description
Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions. This could lead to the user having elevated access to the system.
Affected products
- Mautic: from 1.0.0 before 4.4.12; 1.0.0, 1.0.0-beta2, 1.0.0-beta3, 1.0.0-beta4, 1.0.0-rc1, 1.0.0-rc2 (+2) — fixed in 4.4.12
How to fix
Upgrade to a fixed version: Mautic 4.4.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-27915 or the next vulnerability affects your stack