What’s Vulnerable › Vulnerabilities
CVE-2021-27919
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-11 · updated 2026-06-17
Description
archive/zip in Go 1.16.x before 1.16.1 allows attackers to cause a denial of service (panic) upon attempted use of the Reader.Open API for a ZIP archive in which ../ occurs at the beginning of any filename.
Affected products
- Fedoraproject Fedora: 34, 35
- Go: from 1.16.0 before 1.16.1 — fixed in 1.16.1
How to fix
Upgrade to a fixed version: Go 1.16.1. Check the vendor advisory for mitigations.
References
- https://groups.google.com/g/golang-announce/c/MfiLYjG-RAw
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2MU47VKTNXX33ZDLTI2ORRUY3KLJKU6G/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HM7U5JNS5WU66Q3S26PFIU2ITB2ATTQ4/
- https://security.gentoo.org/glsa/202208-02
- https://groups.google.com/g/golang-announce/c/MfiLYjG-RAw
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2MU47VKTNXX33ZDLTI2ORRUY3KLJKU6G/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HM7U5JNS5WU66Q3S26PFIU2ITB2ATTQ4/
- https://security.gentoo.org/glsa/202208-02
Get alerted when CVE-2021-27919 or the next vulnerability affects your stack