What’s Vulnerable › Vulnerabilities

CVE-2021-27928

Description

A remote code execution issue was discovered in MariaDB 10.2 before 10.2.37, 10.3 before 10.3.28, 10.4 before 10.4.18, and 10.5 before 10.5.9; Percona Server through 2021-03-03; and the wsrep patch through 2021-03-03 for MySQL. An untrusted search path leads to eval injection, in which a database SUPER user can execute OS commands after modifying wsrep_provider and wsrep_notify_cmd. NOTE: this does not affect an Oracle product.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.2.37, 10.3.28, 10.4.18, 10.5.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-27928 or the next vulnerability affects your stack