What’s Vulnerable › Vulnerabilities
CVE-2021-27940
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-03 · updated 2026-06-17
- Weakness: CWE-79
Description
resources/public/js/orchestrator.js in openark orchestrator before 3.2.4 allows XSS via the orchestrator-msg parameter.
Affected products
- Openark Orchestrator: before 3.2.4 — fixed in 3.2.4
How to fix
Upgrade to a fixed version: Openark Orchestrator 3.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/openark/orchestrator/pull/1313
- https://github.com/openark/orchestrator/releases/tag/v3.2.4
- https://www.youtube.com/watch?v=DOYm0DIS3Us
- https://github.com/openark/orchestrator/pull/1313
- https://github.com/openark/orchestrator/releases/tag/v3.2.4
- https://www.youtube.com/watch?v=DOYm0DIS3Us
Get alerted when CVE-2021-27940 or the next vulnerability affects your stack