What’s Vulnerable › Vulnerabilities
CVE-2021-28027
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-05 · updated 2026-06-17
- Weakness: CWE-191
Description
An issue was discovered in the bam crate before 0.1.3 for Rust. There is an integer underflow and out-of-bounds write during the loading of a bgzip block.
Affected products
- Bam Project Bam: before 0.1.3 — fixed in 0.1.3
How to fix
Upgrade to a fixed version: Bam Project Bam 0.1.3. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2021-0027.html
- https://rustsec.org/advisories/RUSTSEC-2021-0027.html
Get alerted when CVE-2021-28027 or the next vulnerability affects your stack