What’s Vulnerable › Vulnerabilities
CVE-2021-28036
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-05 · updated 2026-06-17
- Weakness: CWE-119
Description
An issue was discovered in the quinn crate before 0.7.0 for Rust. It may have invalid memory access for certain versions of the standard library because it relies on a direct cast of std::net::SocketAddrV4 and std::net::SocketAddrV6 data structures.
Affected products
- quinn-rs quinn: before 0.5.4; from 0.6.0 before 0.6.2 — fixed in 0.5.4, 0.6.2
How to fix
Upgrade to a fixed version: quinn-rs quinn 0.5.4, 0.6.2. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2021-0035.html
- https://rustsec.org/advisories/RUSTSEC-2021-0035.html
Get alerted when CVE-2021-28036 or the next vulnerability affects your stack