What’s Vulnerable › Vulnerabilities
CVE-2021-28041
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-05 · updated 2026-10-14
- Weakness: CWE-415
Description
ssh-agent in OpenSSH before 8.5 has a double free that may be relevant in a few less-common scenarios, such as unconstrained agent-socket access on a legacy operating system, or the forwarding of an agent to an attacker-controlled host.
Affected products
- Fedoraproject Fedora: 33, 34
- NetApp Cloud Backup: all versions
- NetApp Hci Compute Node Firmware: all versions
- NetApp Hci Management Node: all versions
- NetApp Hci Storage Node Firmware: all versions
- NetApp Solidfire: all versions
- OpenSSH: from 8.2 before 8.5 — fixed in 8.5
- Oracle Communications Offline Mediation Controller: 12.0.0.3.0
- Oracle Zfs Storage Appliance: 8.8
How to fix
Upgrade to a fixed version: OpenSSH 8.5. Check the vendor advisory for mitigations.
References
- https://github.com/openssh/openssh-portable/commit/e04fd6dde16de1cdc5a4d9946397ff60d96568db
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KQWGII3LQR4AOTPPFXGMTYE7UDEWIUKI/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TXST2CML2MWY3PNVUXX7FFJE3ATJMNVZ/
- https://security.gentoo.org/glsa/202105-35
- https://security.netapp.com/advisory/ntap-20210416-0002/
- https://www.openssh.com/security.html
- https://www.openssh.com/txt/release-8.5
- https://www.openwall.com/lists/oss-security/2021/03/03/1
- https://www.oracle.com//security-alerts/cpujul2021.html
- https://github.com/openssh/openssh-portable/commit/e04fd6dde16de1cdc5a4d9946397ff60d96568db
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KQWGII3LQR4AOTPPFXGMTYE7UDEWIUKI/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TXST2CML2MWY3PNVUXX7FFJE3ATJMNVZ/
Get alerted when CVE-2021-28041 or the next vulnerability affects your stack