What’s Vulnerable › Vulnerabilities
CVE-2021-28091
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-04 · updated 2026-06-17
- Weakness: CWE-347
Description
Lasso all versions prior to 2.7.0 has improper verification of a cryptographic signature.
Affected products
- Debian Linux: 9.0, 10.0
- Entr'ouvert Lasso: before 2.7.0 — fixed in 2.7.0
- Fedoraproject Fedora: 33, 34
How to fix
Upgrade to a fixed version: Entr'ouvert Lasso 2.7.0. Check the vendor advisory for mitigations.
References
- http://listes.entrouvert.com/arc/lasso/
- https://git.entrouvert.org/lasso.git/commit/?id=076a37d7f0eb74001127481da2d355683693cde9
- https://git.entrouvert.org/lasso.git/tree/NEWS?id=v2.7.0
- https://lists.debian.org/debian-lts-announce/2021/06/msg00013.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SI4YAQF4VEV2KHQ6OXXZL7CJK7IZQ3EG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YSVWOHBBWLI2RB5C6TXINFEJRT4YSD3D/
- https://www.debian.org/security/2021/dsa-4926
- http://listes.entrouvert.com/arc/lasso/
- https://git.entrouvert.org/lasso.git/commit/?id=076a37d7f0eb74001127481da2d355683693cde9
- https://git.entrouvert.org/lasso.git/tree/NEWS?id=v2.7.0
- https://lists.debian.org/debian-lts-announce/2021/06/msg00013.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SI4YAQF4VEV2KHQ6OXXZL7CJK7IZQ3EG/
Get alerted when CVE-2021-28091 or the next vulnerability affects your stack