What’s Vulnerable › Vulnerabilities
CVE-2021-28110
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-19 · updated 2026-06-17
- Weakness: CWE-611
Description
/exec in TranzWare e-Commerce Payment Gateway (TWEC PG) before 3.1.27.5 had a vulnerability in its XML parser.
Affected products
- Compassplus Tranzware E-Commerce Payment Gateway: before 3.1.27.5 — fixed in 3.1.27.5
How to fix
Upgrade to a fixed version: Compassplus Tranzware E-Commerce Payment Gateway 3.1.27.5. Check the vendor advisory for mitigations.
References
- https://gist.github.com/kukuxumushi/0b7d90a917ac3480066c4cbf7519b40a
- https://gist.github.com/kukuxumushi/0b7d90a917ac3480066c4cbf7519b40a
Get alerted when CVE-2021-28110 or the next vulnerability affects your stack