What’s Vulnerable › Vulnerabilities
CVE-2021-28126
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-19 · updated 2026-06-17
- Weakness: CWE-79
Description
index.jsp in TranzWare e-Commerce Payment Gateway (TWEC PG) before 3.1.27.5 had a Stored cross-site scripting (XSS) vulnerability
Affected products
- Compassplus Tranzware E-Commerce Payment Gateway: before 3.1.27.5 — fixed in 3.1.27.5
How to fix
Upgrade to a fixed version: Compassplus Tranzware E-Commerce Payment Gateway 3.1.27.5. Check the vendor advisory for mitigations.
References
- https://gist.github.com/kukuxumushi/7436994ef395573023b79652e104a2a0
- https://gist.github.com/kukuxumushi/7436994ef395573023b79652e104a2a0
Get alerted when CVE-2021-28126 or the next vulnerability affects your stack