What’s Vulnerable › Vulnerabilities
CVE-2021-28134
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-11 · updated 2026-06-17
Description
Clipper before 1.0.5 allows remote command execution. A remote attacker may send a crafted IPC message to the exposed vulnerable ipcRenderer IPC interface, which invokes the dangerous openExternal API.
Affected products
- Clipper Project Clipper: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: Clipper Project Clipper 1.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/AkashRajpurohit/clipper/issues/13
- https://github.com/AkashRajpurohit/clipper/pull/14
- https://github.com/AkashRajpurohit/clipper/pull/14/commits/28f1492a12234cf1e6af85c78bf22ee2f5090d19
- https://github.com/AkashRajpurohit/clipper/releases/tag/v1.0.5
- https://github.com/AkashRajpurohit/clipper/issues/13
- https://github.com/AkashRajpurohit/clipper/pull/14
- https://github.com/AkashRajpurohit/clipper/pull/14/commits/28f1492a12234cf1e6af85c78bf22ee2f5090d19
- https://github.com/AkashRajpurohit/clipper/releases/tag/v1.0.5
Get alerted when CVE-2021-28134 or the next vulnerability affects your stack