What’s Vulnerable › Vulnerabilities
CVE-2021-28153
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-11 · updated 2026-10-14
- Weakness: CWE-59
Description
An issue was discovered in GNOME GLib before 2.66.8. When g_file_replace() is used with G_FILE_CREATE_REPLACE_DESTINATION to replace a path that is a dangling symlink, it incorrectly also creates the target of the symlink as an empty file, which could conceivably have security relevance if the symlink is attacker-controlled. (If the path is a symlink to a file that already exists, then the contents of that file correctly remain unchanged.)
Affected products
- Broadcom Brocade Fabric Operating System Firmware: all versions
- Debian Linux: 9.0
- Fedoraproject Fedora: 33
- GNOME GLib: before 2.66.8 — fixed in 2.66.8
How to fix
Upgrade to a fixed version: GNOME GLib 2.66.8. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/glib/-/issues/2325
- https://lists.debian.org/debian-lts-announce/2022/06/msg00006.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6RXTD5HCP2K4AAUSWWZTBKQNHRCTAEOF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ICUTQPHZNZWX2DZR46QFLQZRHVMHIILJ/
- https://security.gentoo.org/glsa/202107-13
- https://security.netapp.com/advisory/ntap-20210416-0003/
- https://gitlab.gnome.org/GNOME/glib/-/issues/2325
- https://lists.debian.org/debian-lts-announce/2022/06/msg00006.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6RXTD5HCP2K4AAUSWWZTBKQNHRCTAEOF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ICUTQPHZNZWX2DZR46QFLQZRHVMHIILJ/
- https://security.gentoo.org/glsa/202107-13
- https://security.netapp.com/advisory/ntap-20210416-0003/
Get alerted when CVE-2021-28153 or the next vulnerability affects your stack