What’s Vulnerable › Vulnerabilities

CVE-2021-28156

Description

HashiCorp Consul Enterprise version 1.8.0 up to 1.9.4 audit log can be bypassed by specifically crafted HTTP events. Fixed in 1.9.5, and 1.8.10.

Affected products

How to fix

Upgrade to a fixed version: HashiCorp Consul 1.8.10, 1.9.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-28156 or the next vulnerability affects your stack