What’s Vulnerable › Vulnerabilities
CVE-2021-28170
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-26 · updated 2026-06-17
- Weakness: CWE-20
Description
In the Jakarta Expression Language implementation 3.0.3 and earlier, a bug in the ELParserTokenManager enables invalid EL expressions to be evaluated as if they were valid.
Affected products
- eclipse Jakarta Expression Language: through 3.0.3
- Oracle Communications Cloud Native Core Policy: 1.14.0
- Oracle WebLogic Server: 14.1.1.0.0
- quarkusio quarkus: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: quarkusio quarkus 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-ee4j/el-ri/issues/155
- https://securitylab.github.com/advisories/GHSL-2020-021-jakarta-el/
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://github.com/eclipse-ee4j/el-ri/issues/155
- https://securitylab.github.com/advisories/GHSL-2020-021-jakarta-el/
- https://www.oracle.com/security-alerts/cpuapr2022.html
Get alerted when CVE-2021-28170 or the next vulnerability affects your stack