What’s Vulnerable › Vulnerabilities
CVE-2021-28290
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-11 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in Skoruba IdentityServer4.Admin before 2.0.0 via unencoded value passed to the data-secret-value parameter.
Affected products
- Identityserver4.Admin Project Identityserver4.Admin: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Identityserver4.Admin Project Identityserver4.Admin 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/skoruba/IdentityServer4.Admin/issues/813
- https://github.com/skoruba/IdentityServer4.Admin/issues/813
Get alerted when CVE-2021-28290 or the next vulnerability affects your stack