What’s Vulnerable › Vulnerabilities
CVE-2021-28302
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-12 · updated 2026-06-17
- Weakness: CWE-770
Description
A stack overflow in pupnp before version 1.14.5 can cause the denial of service through the Parser_parseDocument() function. ixmlNode_free() will release a child node recursively, which will consume stack space and lead to a crash.
Affected products
- pupnp: before 1.14.5 — fixed in 1.14.5
How to fix
Upgrade to a fixed version: pupnp 1.14.5. Check the vendor advisory for mitigations.
References
- https://github.com/pupnp/pupnp/issues/249
- https://github.com/pupnp/pupnp/releases/tag/release-1.14.5
- https://github.com/pupnp/pupnp/issues/249
- https://github.com/pupnp/pupnp/releases/tag/release-1.14.5
Get alerted when CVE-2021-28302 or the next vulnerability affects your stack