What’s Vulnerable › Vulnerabilities

CVE-2021-28359: Apache Airflow Reflected XSS via Origin Query Argument in URL

Description

The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions <1.10.15 in 1.x series and affects 2.0.0 and 2.0.1 and 2.x series. This is the same as CVE-2020-13944 & CVE-2020-17515 but the implemented fix did not fix the issue completely. Update to Airflow 1.10.15 or 2.0.2. Please also update your Python version to the latest available PATCH releases of the installed MINOR versions, example update to Python 3.6.13 if you are on Python 3.6. (Those contain the fix for CVE-2021-23336 https://nvd.nist.gov/vuln/detail/CVE-2021-23336).

Affected products

How to fix

Upgrade to a fixed version: Apache Airflow 1.10.15, 2.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-28359 or the next vulnerability affects your stack