What’s Vulnerable › Vulnerabilities
CVE-2021-28374
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-15 · updated 2026-06-17
- Weakness: CWE-732
Description
The Debian courier-authlib package before 0.71.1-2 for Courier Authentication Library creates a /run/courier/authdaemon directory with weak permissions, allowing an attacker to read user information. This may include a cleartext password in some configurations. In general, it includes the user's existence, uid and gids, home and/or Maildir directory, quota, and some type of password information (such as a hash).
Affected products
- Debian Courier-Authlib: before 0.71.1-2 — fixed in 0.71.1-2
- Debian Linux: 9.0
How to fix
Upgrade to a fixed version: Debian Courier-Authlib 0.71.1-2. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/984810
- https://lists.debian.org/debian-lts-announce/2021/04/msg00011.html
- https://bugs.debian.org/984810
- https://lists.debian.org/debian-lts-announce/2021/04/msg00011.html
Get alerted when CVE-2021-28374 or the next vulnerability affects your stack