What’s Vulnerable › Vulnerabilities

CVE-2021-28398

Description

A privileged attacker in GeoNetwork before 3.12.0 and 4.x before 4.0.4 can use the directory harvester before-script to execute arbitrary OS commands remotely on the hosting infrastructure. A User Administrator or Administrator account is required to perform this. This occurs in the runBeforeScript method in harvesters/src/main/java/org/fao/geonet/kernel/harvest/harvester/localfilesystem/LocalFilesystemHarvester.java. The earliest affected version is 3.4.0.

Affected products

How to fix

Upgrade to a fixed version: geonetwork core-geonetwork 3.12.0, 4.0.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-28398 or the next vulnerability affects your stack