What’s Vulnerable › Vulnerabilities
CVE-2021-28543
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-16 · updated 2026-06-17
- Weakness: CWE-476
Description
Varnish varnish-modules before 0.17.1 allows remote attackers to cause a denial of service (daemon restart) in some configurations. This does not affect organizations that only install the Varnish Cache product; however, it is common to install both Varnish Cache and varnish-modules. Specifically, an assertion failure or NULL pointer dereference can be triggered in Varnish Cache through the varnish-modules header.append() and header.copy() functions. For some Varnish Configuration Language (VCL) files, this gives remote clients an opportunity to cause a Varnish Cache restart. A restart reduces overall availability and performance due to an increased number of cache misses, and may cause higher load on backend servers.
Affected products
- Fedoraproject Fedora: 34
- Varnish-Cache Varnish-Modules: before 0.17.1 — fixed in 0.17.1
- Varnish-Cache Varnish-Modules Klarlack: before 0.17.1 — fixed in 0.17.1
How to fix
Upgrade to a fixed version: Varnish-Cache Varnish-Modules 0.17.1; Varnish-Cache Varnish-Modules Klarlack 0.17.1. Check the vendor advisory for mitigations.
References
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OPFBRQUJNWHCB3GQHSSAPRLQU6Q6PY43/
- https://varnish-cache.org/security/VSV00006.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OPFBRQUJNWHCB3GQHSSAPRLQU6Q6PY43/
- https://varnish-cache.org/security/VSV00006.html
Get alerted when CVE-2021-28543 or the next vulnerability affects your stack