What’s Vulnerable › Vulnerabilities
CVE-2021-28548: Adobe Photoshop parsing JS buffer overflow vulnerability could lead to arbitrary code execution
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-15 · updated 2026-06-17
- Weakness: CWE-120
Description
Adobe Photoshop versions 21.2.6 (and earlier) and 22.3 (and earlier) are affected by a Buffer Overflow vulnerability when parsing a specially crafted JSX file. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Photoshop: through 21.2.6; from 22.0 before 22.3 — fixed in 22.3
How to fix
Upgrade to a fixed version: Adobe Photoshop 22.3. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/photoshop/apsb21-28.html
- https://helpx.adobe.com/security/products/photoshop/apsb21-28.html
Get alerted when CVE-2021-28548 or the next vulnerability affects your stack