What’s Vulnerable › Vulnerabilities
CVE-2021-28556: Magento Commerce DOM-based cross-site scripting (XSS) could lead to arbitrary javascript execution
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a DOM-based Cross-Site Scripting vulnerability on mage-messages cookies. Successful exploitation could lead to arbitrary JavaScript execution by an unauthenticated attacker. User interaction is required for successful exploitation.
Affected products
- Adobe Magento Commerce: before 2.3.7; from 2.4.0 through 2.4.2 — fixed in 2.3.7
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.3.7. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb21-30.html
- https://helpx.adobe.com/security/products/magento/apsb21-30.html
Get alerted when CVE-2021-28556 or the next vulnerability affects your stack