What’s Vulnerable › Vulnerabilities

CVE-2021-28563: Magento Commerce improper Authorization via the 'Create Customer' endpoint

Description

Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper Authorization vulnerability via the 'Create Customer' endpoint. Successful exploitation could lead to unauthorized modification of customer data by an unauthenticated attacker. Access to the admin console is required for successful exploitation.

Affected products

How to fix

Upgrade to a fixed version: Adobe Magento Commerce 2.3.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-28563 or the next vulnerability affects your stack