What’s Vulnerable › Vulnerabilities
CVE-2021-28583: Magento Commerce insecure storage of sensitive documentation
- Severity: medium (CVSS 4.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-28 · updated 2026-06-17
- Weakness: CWE-657
Description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a Violation of Secure Design Principles vulnerability in RMA PDF filename formats. Successful exploitation could allow an attacker to get unauthorized access to restricted resources.
Affected products
- Adobe Magento Commerce: before 2.3.6; 2.3.6, 2.3.6-p1, 2.4.1, 2.4.1-p1, 2.4.2 — fixed in 2.3.6
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.3.6. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb21-30.html
- https://helpx.adobe.com/security/products/magento/apsb21-30.html
Get alerted when CVE-2021-28583 or the next vulnerability affects your stack