What’s Vulnerable › Vulnerabilities
CVE-2021-28584: Magento Commerce path traversal vulnerability in child theme store creation
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-28 · updated 2026-06-17
- Weakness: CWE-22
Description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a Path Traversal vulnerability when creating a store with child theme.Successful exploitation could lead to arbitrary file system write by an authenticated attacker. Access to the admin console is required for successful exploitation.
Affected products
- Adobe Magento Commerce: before 2.3.6; 2.3.6, 2.3.6-p1, 2.4.1, 2.4.1-p1, 2.4.2 — fixed in 2.3.6
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.3.6. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb21-30.html
- https://helpx.adobe.com/security/products/magento/apsb21-30.html
Get alerted when CVE-2021-28584 or the next vulnerability affects your stack