What’s Vulnerable › Vulnerabilities
CVE-2021-28585: Magento Commerce improper input validation in customer customer webapi
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-28 · updated 2026-06-17
- Weakness: CWE-20
Description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper input validation vulnerability in the New customer WebAPI.Successful exploitation could allow an attacker to send unsolicited spam e-mails.
Affected products
- Adobe Magento Commerce: before 2.3.6; 2.3.6, 2.3.6-p1, 2.4.1, 2.4.1-p1, 2.4.2 — fixed in 2.3.6
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.3.6. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb21-30.html
- https://helpx.adobe.com/security/products/magento/apsb21-30.html
Get alerted when CVE-2021-28585 or the next vulnerability affects your stack