What’s Vulnerable › Vulnerabilities
CVE-2021-28623: Adobe Premiere Elements Privilege Escalation Vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-28 · updated 2026-06-17
- Weakness: CWE-379
Description
Adobe Premiere Elements version 5.2 (and earlier) is affected by an insecure temporary file creation vulnerability. An unauthenticated attacker could leverage this vulnerability to call functions against the installer to perform high privileged actions. Exploitation of this issue does not require user interaction.
Affected products
- Adobe Premiere Elements: before 5.3 — fixed in 5.3
How to fix
Upgrade to a fixed version: Adobe Premiere Elements 5.3. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/premiere_elements/apsb21-47.html
- https://helpx.adobe.com/security/products/premiere_elements/apsb21-47.html
Get alerted when CVE-2021-28623 or the next vulnerability affects your stack