What’s Vulnerable › Vulnerabilities
CVE-2021-28652
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-401
Description
An issue was discovered in Squid before 4.15 and 5.x before 5.0.6. Due to incorrect parser validation, it allows a Denial of Service attack against the Cache Manager API. This allows a trusted client to trigger memory leaks that. over time, lead to a Denial of Service via an unspecified short query string. This attack is limited to clients with Cache Manager API access privilege.
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 33, 34
- Squid: from 1.0 before 4.15; from 5.0 before 5.0.6 — fixed in 4.15, 5.0.6
How to fix
Upgrade to a fixed version: Squid 4.15, 5.0.6. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Oct/14
- http://www.openwall.com/lists/oss-security/2023/10/11/3
- https://bugs.squid-cache.org/show_bug.cgi?id=5106
- https://github.com/squid-cache/squid/security/advisories/GHSA-m47m-9hvw-7447
- https://lists.debian.org/debian-lts-announce/2021/06/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LSQ3U54ZCNXR44QRPW3AV2VCS6K3TKCF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/T4EPIWUZDJAXADDHVOPKRBTQHPBR6H66/
- https://www.debian.org/security/2021/dsa-4924
- http://seclists.org/fulldisclosure/2023/Oct/14
- http://www.openwall.com/lists/oss-security/2023/10/11/3
- https://bugs.squid-cache.org/show_bug.cgi?id=5106
- https://github.com/squid-cache/squid/security/advisories/GHSA-m47m-9hvw-7447
Get alerted when CVE-2021-28652 or the next vulnerability affects your stack