What’s Vulnerable › Vulnerabilities
CVE-2021-28667
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-18 · updated 2026-06-17
- Weakness: CWE-835
Description
StackStorm before 3.4.1, in some situations, has an infinite loop that consumes all available memory and disk space. This can occur if Python 3.x is used, the locale is not utf-8, and there is an attempt to log Unicode data (from an action or rule name).
Affected products
- Stackstorm: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: Stackstorm 3.4.1. Check the vendor advisory for mitigations.
References
- https://stackstorm.com/2021/03/10/stackstorm-v3-4-1-security-fix/
- https://stackstorm.com/2021/03/10/stackstorm-v3-4-1-security-fix/
Get alerted when CVE-2021-28667 or the next vulnerability affects your stack