What’s Vulnerable › Vulnerabilities
CVE-2021-28800: Command Injection Vulnerability in QTS
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-24 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability has been reported to affect QNAP NAS running legacy versions of QTS. If exploited, this vulnerability allows attackers to execute arbitrary commands in a compromised application. This issue affects: QNAP Systems Inc. QTS versions prior to 4.3.6.1663 Build 20210504; versions prior to 4.3.3.1624 Build 20210416. This issue does not affect: QNAP Systems Inc. QTS 4.5.3. QNAP Systems Inc. QuTS hero h4.5.3. QNAP Systems Inc. QuTScloud c4.5.5.
Affected products
- QNAP QTS: before 4.3.3.1624; from 4.3.4 before 4.3.6.1663 — fixed in 4.3.3.1624, 4.3.6.1663
How to fix
Upgrade to a fixed version: QNAP QTS 4.3.3.1624, 4.3.6.1663. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-28
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-28
Get alerted when CVE-2021-28800 or the next vulnerability affects your stack