What’s Vulnerable › Vulnerabilities
CVE-2021-28801: Out-of-Bounds Read Vulnerability in QSS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-11 · updated 2026-06-17
- Weakness: CWE-125
Description
An out-of-bounds read vulnerability has been reported to affect certain QNAP switches running QSS. If exploited, this vulnerability allows attackers to read sensitive information on the system. This issue affects: QNAP Systems Inc. QSS versions prior to 1.0.2 build 20210122 on QSW-M2108-2C; versions prior to 1.0.2 build 20210122 on QSW-M2108-2S; versions prior to 1.0.2 build 20210122 on QSW-M2108R-2C.
Affected products
- QNAP Systems Inc. QSS: before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QSS 1.0.2. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-23
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-23
Get alerted when CVE-2021-28801 or the next vulnerability affects your stack