What’s Vulnerable › Vulnerabilities
CVE-2021-28805: Inclusion of Sensitive Information in QSS
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-11 · updated 2026-06-17
- Weakness: CWE-540
Description
Inclusion of sensitive information in the source code has been reported to affect certain QNAP switches running QSS. If exploited, this vulnerability allows attackers to read application data. This issue affects: QNAP Systems Inc. QSS versions prior to 1.0.3 build 20210505 on QSW-M2108-2C; versions prior to 1.0.3 build 20210505 on QSW-M2108-2S; versions prior to 1.0.3 build 20210505 on QSW-M2108R-2C; versions prior to 1.0.12 build 20210506 on QSW-M408.
Affected products
- QNAP Systems Inc. QSS: before 1.0.3; before 1.0.12 — fixed in 1.0.12, 1.0.3
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QSS 1.0.12, 1.0.3. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-24
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-24
Get alerted when CVE-2021-28805 or the next vulnerability affects your stack