What’s Vulnerable › Vulnerabilities

CVE-2021-28806: DOM-Based XSS Vulnerability in QTS and QuTS hero

Description

A DOM-based XSS vulnerability has been reported to affect QNAP NAS running QTS and QuTS hero. If exploited, this vulnerability allows attackers to inject malicious code. This issue affects: QNAP Systems Inc. QTS versions prior to 4.5.3.1652 Build 20210428. QNAP Systems Inc. QuTS hero versions prior to h4.5.2.1638 Build 20210414. QNAP Systems Inc. QuTScloud versions prior to c4.5.5.1656 Build 20210503. This issue does not affect: QNAP Systems Inc. QTS 4.3.6; 4.3.3.

Affected products

How to fix

Upgrade to a fixed version: QNAP QTS 4.5.3.1652; QNAP Systems Inc. QuTS hero h4.5.2.1638; QNAP Systems Inc. QuTScloud c4.5.5.1656. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-28806 or the next vulnerability affects your stack