What’s Vulnerable › Vulnerabilities

CVE-2021-28807: Post-Authentication Reflected XSS Vulnerability in Q'center

Description

A post-authentication reflected XSS vulnerability has been reported to affect QNAP NAS running Q’center. If exploited, this vulnerability allows remote attackers to inject malicious code. QNAP have already fixed this vulnerability in the following versions of Q’center: QTS 4.5.3: Q’center v1.12.1012 and later QTS 4.3.6: Q’center v1.10.1004 and later QTS 4.3.3: Q’center v1.10.1004 and later QuTS hero h4.5.2: Q’center v1.12.1012 and later QuTScloud c4.5.4: Q’center v1.12.1012 and later

Affected products

How to fix

Upgrade to a fixed version: QNAP Q'Center 1.10.1004, 1.12.1012. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-28807 or the next vulnerability affects your stack