What’s Vulnerable › Vulnerabilities
CVE-2021-28812: Command Injection Vulnerability in Video Station
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-03 · updated 2026-06-17
- Weakness: CWE-77
Description
A command injection vulnerability has been reported to affect certain versions of Video Station. If exploited, this vulnerability allows remote attackers to execute arbitrary commands. This issue affects: QNAP Systems Inc. Video Station versions prior to 5.5.4 on QTS 4.5.2; versions prior to 5.5.4 on QuTS hero h4.5.2; versions prior to 5.5.4 on QuTScloud c4.5.4. This issue does not affect: QNAP Systems Inc. Video Station on QTS 4.3.6; on QTS 4.3.3.
Affected products
- QNAP Systems Inc. Video Station: before 5.5.4 — fixed in 5.5.4
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Video Station 5.5.4. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-21
- https://www.qnap.com/zh-tw/security-advisory/qsa-21-21
Get alerted when CVE-2021-28812 or the next vulnerability affects your stack